repaired games from bad tapes

Use this forum to submit new files for the download section of the archive. I will check each submission and upload it to the archive on a regular basis.
User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Mon May 20, 2019 6:19 pm

robcfg wrote:
Mon May 20, 2019 2:54 pm
Screaming Abdabs comes to mind. It has some standard blocks and then it switches to a custom loader with no standard block structure. Does it load on Mame?
Yes, that custom loader works!.
even the old TOSEC version that is corrupt with a few random hex [54] instead of [55] works???

here's another one that failed to load in MAME or Xroar.
Gis a Job.

i think it has an intentional error on the tape which doesn't read in the CAS conversion.
or it is just a bad copy.
i removed the error, and fixed the gaps.
it works in MAME and Xroar now. :D
Attachments
Gi's A Job (Blaby Computer Games)[fixed].cas
(36.52 KiB) Downloaded 45 times
gisa.png
gisa.png (5.56 KiB) Viewed 982 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Wed May 22, 2019 4:26 pm

Hotel on Mayfair (Datacom + Preston)

fixed CAS to load Data file correctly.
and found the missing the 2-6 Player game mode (HOM2)
Attachments
hom2.png
hom2.png (5.24 KiB) Viewed 968 times
hom1.png
hom1.png (5.39 KiB) Viewed 968 times
hom.png
hom.png (6.04 KiB) Viewed 968 times
Hotel on Mayfair (Datacom - Preston).zip
(31.91 KiB) Downloaded 45 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Mon May 27, 2019 3:57 pm

Johnny Reb - Working!

Both the WAV and CAS in the archive failed to load.
found an alternative WAV and converted it to CAS.
Attachments
Johnny Reb (M.C. Lothlorien).cas
(23.47 KiB) Downloaded 43 times
Johnny Reb.png
Johnny Reb.png (783 Bytes) Viewed 942 times
Johnny Reb_2.png
Johnny Reb_2.png (2.44 KiB) Viewed 942 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Thu May 30, 2019 12:10 pm

Larkspur Trilogy (Doublet) ;)

H Bullman & J Smallwood version is missing from the archive download.
I found a CAS version with a corrupt last block and fixed it.

The John Penn CAS version has different filenames and a few extra lines of BASIC.
i fixed the incorrect spacing between the blocks, so it now loads in half the time.

included are the restart save games (Side B) of the tapes.
Attachments
Larkspur (HB-JS + JP).zip
(52.11 KiB) Downloaded 40 times
Larkspur.png
Larkspur.png (3.93 KiB) Viewed 913 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Sat Jun 01, 2019 1:54 pm

Lucifer's Kingdom.
fixed and modified CAS for Dragon32.

The Original tape crashes on Dragon32 [resets], when loaded in Dragon64 the fire button doesn't work.

Joystick control in Xroar goes a bit funny (no auto centre).
so the ship floats diagonally up the screen.
if you select Keyboard for LEFT joystick the game control is more stable (cursors and / for fire).

control is very stable in MAME.
Attachments
Lucifer's Kingdom (ORANGE).png
Lucifer's Kingdom (ORANGE).png (2.61 KiB) Viewed 897 times
Lucifer's Kingdom (ORANGE)_1.png
Lucifer's Kingdom (ORANGE)_1.png (6.1 KiB) Viewed 897 times
Lucifer's Kingdom (Orange)[fix].cas
(33.45 KiB) Downloaded 40 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Sun Jun 02, 2019 2:05 pm

Match Maker (Orange)
tape is on the M.I.A. list, so i made this from the disk.

the CAS loader only shows the loading screen when the DDOS cart is inserted?.
Attachments
Matchmaker_1.png
Matchmaker_1.png (3.05 KiB) Viewed 878 times
match maker (Orange)[ddos].cas
(24.46 KiB) Downloaded 41 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Tue Jun 04, 2019 11:07 am

Morbid Mansion (Blaby)

Failed to load in MAME and Xroar with an error on the data read.
Attachments
morbid.png
morbid.png (2.52 KiB) Viewed 855 times
Morbid Mansion (Blaby Computer Games)[fix].cas
(35.1 KiB) Downloaded 39 times

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Sun Jun 09, 2019 1:42 pm

Cuthbert in the Mines
This is a weird one in emulators.

WAV has a corrupt loding screen an takes [3:42] to load.
converted CAS takes [8:29] to load.

when the CAS loader first block is padded with zero's to make it 256bytes.
the load time is reduced in MAME to [3:29]

so it's yet another MAME error.
Attachments
Cuthbert In The Mines (1983)(Microdeal)[fix test].CAS
(38.44 KiB) Downloaded 33 times
mines wav.png
mines wav.png (3.89 KiB) Viewed 787 times
Last edited by .mad. on Mon Jun 10, 2019 6:53 pm, edited 3 times in total.

User avatar
robcfg
Posts: 1238
Joined: Sat Apr 04, 2009 10:16 pm
Location: Stockholm, Sweden

Re: repaired games from bad tapes

Post by robcfg » Sun Jun 09, 2019 3:30 pm

Where does it take 8:29 to load?

I just tried on XRoar and the CAS file loads Ok (loading screen has no error), and it takes 3:50 to do so.

You seem to have shortened the sync bytes from 256 to 128 and you have at least one block that yields a crc error.

User avatar
.mad.
Posts: 99
Joined: Fri Mar 15, 2019 4:22 pm
Location: Born in the North

Re: repaired games from bad tapes

Post by .mad. » Mon Jun 10, 2019 3:36 pm

robcfg wrote:
Sun Jun 09, 2019 3:30 pm
Where does it take 8:29 to load?

I just tried on XRoar and the CAS file loads Ok (loading screen has no error), and it takes 3:50 to do so.

You seem to have shortened the sync bytes from 256 to 128 and you have at least one block that yields a crc error.
Hi Rob,

Thanks for the info. ;)
i have not noticed the CRC error. could be it is ignored by the emulator?.

The WAVE (not CAS) has a corrupt loading screen in Xroar and MAME.
when that CAS is loaded in MAME it takes about 8:19 for me.

i padded the loader in the fixed file above.
does it pass your CRC check.
only the first block is edited with zeros, all syncs are back to original 256bytes.

sorry.... i know you don't like these mods. ;)
it is only emulator compatability i am looking for.

Post Reply