Problems with DOS using an Y-type connection

For the discussion of all hardware related topics.
bluearcus
Posts: 86
Joined: Wed Sep 07, 2016 4:45 pm

Re: Problems with DOS using an Y-type connection

Post by bluearcus »

That's really excellent news!
dublevay
Posts: 80
Joined: Wed Jan 23, 2019 3:41 pm

Re: Problems with DOS using an Y-type connection

Post by dublevay »

At bluearcus' suggestion (well, I think that's him) I have now put together a somewhat neater pull-up solution which would mean that the Oojamaflip would still work with the DMSX2+ and CocoSDC as is without needing additional pull-ups. It's a 6809/6309 adapter with the address and R/W pull-ups incorporated - and it comes in just slightly wider than the 6809 footprint itself.

This would improve the SYNC situation on stock D32s, D64s, D200s and Tano 64s, as well as (I believe) Coco 1s and 2s. I am not sure if it would be compatible with the Tandy MPI though, as do not know if that also has the pull-ups - or just pure buffering. I know that a special MPI was launched for the Coco 3. I do not know if there are yet any other real-world Dragon examples where this is needed, apart from the DMSX2+ and the CocoSDC.

Anyway, here it is...I will order a small quantity of these boards soon.
Device_top.png
Device_top.png (417.22 KiB) Viewed 1138 times
Device_bottom.png
Device_bottom.png (262.62 KiB) Viewed 1138 times
Device_front.png
Device_front.png (260.28 KiB) Viewed 1138 times
tjewell
Posts: 304
Joined: Mon Oct 19, 2009 4:58 pm
Location: Cambridge, England

Re: Problems with DOS using an Y-type connection

Post by tjewell »

Just caught up on this thread - great detective work everyone! As I'm sure you're all well aware, I've had all manner of 'fun' with my over-expanded franken-dragons, and it's wonderful to hear there's a potential solution to my woes. Looking forward to getting hold of one of your boards, John!
Post Reply