xroar rompath

A place to discuss everything Dragon related that doesn't fall into the other categories.
Post Reply
prime
Posts: 258
Joined: Fri Apr 10, 2009 1:40 am

xroar rompath

Post by prime »

Hi all,

I'm having problems getting the rompath command line parameter to work....

I have the windows version of xroar (and thge roms) installled in :

G:\Emulate\xroar\xroar-0.36.2-w64

If I change to that directory and run xroar (either from windows explorer, or from a cmd window), everything works and the emulation starts with the default machine.

However if I change to another drive / directory and try and specify the rompath, the emulation starts but with the checkerboard (no roms loaded).

e.g. :
c:
g:\emulate\xroar\xroar-0.36.2-w64\xroar.exe -rompath g:\Emulate\xroar\xroar-0.35.2-w64

Any clues as to what is wrong?

If I follow what the documentation says and insert a = it just silently dies.....

g:\emulate\xroar\xroar-0.36.2-w64\xroar.exe -rompath=g:\Emulate\xroar\xroar-0.35.2-w64

Cheers.

Phill.
sixxie
Posts: 1181
Joined: Fri Jul 18, 2008 8:36 am
Location: Hertfordshire
Contact:

Re: xroar rompath

Post by sixxie »

You might try doubling up those backslashes - else XRoar will see them as escape sequences (or use forward slashes instead - they work under Windows).

... and you might also find that the latest snapshots in http://www.6809.org.uk/tmp/xroar/ changes this behaviour: it now expects that file paths on the command line are escaped to your satisfaction by the shell (while still allowing escape sequences in options that aren't file paths).
Post Reply