New update for the DOSPlus5.0 extended & CoCo-SDC

A place to discuss everything Dragon related that doesn't fall into the other categories.

New update for the DOSPlus5.0 extended & CoCo-SDC

Postby pser1 » Wed Dec 13, 2017 12:31 pm

Hello,
Mike Miller found out that the last added feature for autobooting a disk when starting the computer by pressing the spacebar worked perfect
for NitrOS-9 disks but failed on OS-9 disks, both Dragon Data and Eurohard versions.
Anyway, all of them worked flawlessly from the prompt by issuing a simple BOOT command. Thanks a lot for letting me know!!
I have modified the boot code so that it works with all of those O.S.
The version now is v.0.25.07 - In the atached zip you will find:
- Boot Order for CoCo-SDC.txt - - - a text explaining how it works on starting
- Changes v0.25.07 - - - - - - - - - - the mods history
- DP50Ext commands.doc - - - - - - a short explanation for the added commands
- DW42-2507.asm - - - - - - - - - - - the source code
- UPD2507.VDK - - - - - - - - - - - - - a virtual file to update your CoCo-SDC
The VDK contains a Basic program named UPDBANK.BAS that once run will ask you for a bank number to flash the new version
You can choose even the same you used to start
cheers
pere
EDIT: DELETED Atachment ... I copied a wrong compilation. WILL UPLOAD CORRECT ONE
EDIT2: Correct file updated!
DP50E v25.07.zip
(82.07 KiB) Downloaded 41 times

PS You will find the thread history here:
viewtopic.php?f=5&t=5363
pser1
 
Posts: 992
Joined: Sun Mar 25, 2012 7:32 pm
Location: Barcelona (SPAIN)

Re: New update for the DOSPlus5.0 extended & CoCo-SDC

Postby pser1 » Thu May 24, 2018 4:30 pm

Hello,
again with you to upload an update for the DragonPlus5.0 extended. The version now is 25.08
John Whitworth has found a very hidden bug that only can be spotted if you, after starting the Dragon with CoCo-SDC pressing no keys,
and once received the OK prompt, issue any command related to SOUND or PLAY, they both hang the computer!
The reason is that this starting way of the DosPlus50 extended doesn't re-enable the interrupts before calling the Basic Interpreter :cry:
The other two starting ways, do not show this issue
- Pressing Shift to avoid Drivewire process
- Pressing Space to boot a disc from drive1

I think it is *not mandatory* for the users to update, because 99,99% of the time after starting the computer we call
Guillaume's explorer or we enter the commands SDIR or SDRIVE as needed and anything we do that calls the interpreter
solves the problem because the interrupts are enabled for free.

Anyway, I think I had to correct this bug and upload an update for anyone that wants to avoid this happening on its setup.
I have updated my CoCo-SDC and have verified that all variants work well now.

In the zip you will find the ROM to be used on XRoar, a text file with the changes history and an VDK that you could use to update your card.
Just copy it in the root of your card and then
- SDRIVE1,"DP2508UP.VDK"
- you can verify it is there with "SDRIVE" or better with "DIR1"
- RUN"UPDBANK" and select a free bank or the same you are using now, when asked, just press C to confirm

cheers
pere
DP50E v25.08.zip
(41.23 KiB) Downloaded 16 times
pser1
 
Posts: 992
Joined: Sun Mar 25, 2012 7:32 pm
Location: Barcelona (SPAIN)


Return to Dragon General

Who is online

Users browsing this forum: No registered users and 1 guest

cron